Как установить MikroTik Cloud Hosted Router на KVM VPS

Материал из Wiki - Iphoster - the best ever hosting and support. 2005 - 2023
Перейти к:навигация, поиск

Доступная цена

Как установить MikroTik Cloud Hosted Router на KVM VPS

Видео инструкция:

Ниже алгоритм действия для установки MikroTik Cloud Hosted Router на KVM VPS IPHOSTER (цена от 1.95$ в месяц):

1) Купить любой тариф KVM VPS с ОС CentOS 7 по ссылке: https://iphoster.net/order?do=order&vid=vds
2) Зайти на сервер по ssh и выполнить команду для скачивания образа и развернуть его на диск:
# yum install unzip -y && wget  --no-check-certificate  https://download.mikrotik.com/routeros/6.48.6/chr-6.48.6.img.zip 
# unzip chr-6.48.6.img.zip 
# dd if=chr-6.48.6.img of=/dev/vda bs=4M oflag=sync
Для CHR 7.13 Stable:
# mount -t tmpfs tmpfs /tmp/  && cd /tmp/
# yum install unzip -y && wget  --no-check-certificate   https://download.mikrotik.com/routeros/7.13/chr-7.13.img.zip
# unzip chr-7.13.img.zip
# dd if=chr-7.13.img of=/dev/vda bs=4M oflag=sync
Ребутим VPS:
# echo 1 > /proc/sys/kernel/sysrq
# echo b > /proc/sysrq-trigger
либо
Перезагрузить сервер через VMManager 6
Диск после ребута ОС - автоматически будет размечен.
3) Зайти через VMManager 6 --> VNC в микротик: 
admin, пароль пустой, попросит установить свой пароль
4) Настроить IP и шлюз по-умолчанию через команды:
/ip address add address=xx.xx.xx.xx/24 interface=ether1  
/ip route add gateway=xx.xx.xx.254
Второй вариант настройки сети (если шлюз из другой подсети):
> ip address add address=xx.xx.xx.xx/32 network=xx.xx.xx.254 broadcast xx.xx.xx.xx interface=ether1
> ip route add dst-address=0.0.0.0/0 gateway=xx.xx.xx.254
где:
xx.xx.xx.254 - шлюз по-умолчанию
xx.xx.xx.xx - IP VPS
5) Теперь можно подключиться через winbox к нашему роутеру.
Настоятельно рекомендуем сразу создать своего пользователя и удалить пользователя admin, поменять порт ssh, отключить telnet сервис.
Изменить пароль от пользователя admin можно командой в консоле
[admin@MikroTik] > user set admin password="new_password"

Если у Вас что-то не получается - Вы можете создать тикет в техническую поддержку и запросить установку Mikrotik ОС на VPS через тикет

https://iphoster.net/billing?do=tickets --> Добавить тикет


Установка "быстро" через скрипт на CentOS 7:

# bash <(wget --no-check-certificate -O - https://iphwiki.net/files/install-mik-7.sh)


Новые релизы MikroTik Cloud Hosted Router можно всегда найти по ссылке:

Установка openvpn сервера на mikrotik (chr) + nat (маскарадинг): https://iphwiki.net/wiki/Mikrotik_-_настройка_openvpn_сервера

Также там можно скачать WinBox и Bandwidth Test


Основными преимуществами Сloud Hosted Router перед версией Mirotik RouterOS являются:

1) Нет ограничений на функционал ПО. В отличие от уровней лицензии Mikrotik RouterOS где присутствуют количественные ограничения, например на туннели или одновременное подключение пользователей, CHR имеет ограничения только на скорость каждого интерфейса в сети.
2) Мобильность использования. В отличие от Mikrotik RouterOS, где лицензия жестко привязывается к носителю (то есть оборудованию компании Mikrotik), лицензия CHR привязывается к Вашему личному кабинетe на сайте разработчика и не зависит от конкретного оборудования. Это позволяет Вам пользоваться программным обеспечением практически из любой точки мира, спокойно менять железо или сервера, либо например, вообще развернуть виртуальную машину с этим ПО на каком-либо виртуальном хостинге.
3) Свобода выбора «железа» и ПО. Если у Вас уже есть мощный сервер или современный PC и нет нужды покупать готовый роутер – можно использовать CHR. Вам достаточно приобрести лицензию нужного вида, развернуть виртуальную машину и начать пользоваться виртуальным роутером, без лишних затрат на готовое оборудование.
4) Легкость активации и работы. К одному личному кабинету может быть привязано неограниченной количество лицензий CHR. Для того, чтобы начать  пользоваться достаточно:
- выбрать нужный уровень лицензии на сайте и оформить заказ
- логин от личного кабинета на сайте mikrotik.com
- после поступления оплаты мы подготовим активацию под Ваш логин
- Вам нужно использовать Ваш логин от личного кабинета на mikrotik.com для запуска работы лицензии Mikrotik Cloud Hosted Router
Индекс цитирования