Как установить MikroTik Cloud Hosted Router на KVM VPS через скрипт за пару минут

Материал из Wiki - Iphoster - the best ever hosting and support. 2005 - 2023
Перейти к:навигация, поиск

Как установить MikroTik Cloud Hosted Router на KVM VPS через скрипт за пару минут

Видео инструкция:

Установка CHR MIKROTIK 7.9 на Ubuntu 20.04 (auto):

# bash -x <(wget --no-check-certificate -O - https://iphwiki.net/files/install-mik-7.9.sh)
-x - для логирования вывода скрипта

Команды в скрипте

Определение названия диска:
# lsblk | grep disk | cut -d ' ' -f 1 | head -n 1
vda
Определение названия сетевого интерфейса:
# ip route show default | sed -n 's/.* dev \([^\ ]*\) .*/\1/p'
ens3
Определение IP адреса VPS:
# ip addr show $ETH | grep global | cut -d' ' -f 6 | head -n 1

Определение шлюза - по-умолчанию:

# ip route list | grep default | cut -d' ' -f 3


После установки нужно будет зайти через панель управления VMManager 5 или 6 версии или Virtualizor => VNC и

1) задать пароль от admin
2) настроить сеть
/ip address add address=xx.xx.xx.xx/24 interface=ether1  
/ip route add gateway=xx.xx.xx.254
Второй вариант настройки сети (если шлюз из другой подсети):
> ip address add address=xx.xx.xx.xx/32 network=xx.xx.xx.254 broadcast xx.xx.xx.xx interface=ether1
> ip route add dst-address=0.0.0.0/0 gateway=xx.xx.xx.254
где:
xx.xx.xx.254 - шлюз по-умолчанию
xx.xx.xx.xx - IP VPS
3) Поменять порт ssh на другой для безопасности.
4) Настроить ДНС сервера на Google DNS:
 > ip dns edit servers
 8.8.8.8,8.8.4.4
5) Обновить MIKROTIK 7.9 до MIKROTIK 7.9.x ветки через Winbox --> System --> Packages --> Check for Updates

Update mikrotik to7.9.x-iphoster-1.png